$re = '/^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\.(?:[a-z])+?$/im';
$str = 'facebook.com
facebook-test.com
bbc.co.uk
bbc-test.co.uk
192.168.0.1
0.1
ee-outage.s3.amazonaws.com
an-éxample-domain.com
an-x%mple-domain.com
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz
my\'domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);