import Foundation
let pattern = #"^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\.(?:[a-z])+?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
facebook.com
facebook-test.com
bbc.co.uk
bbc-test.co.uk
192.168.0.1
0.1
ee-outage.s3.amazonaws.com
an-éxample-domain.com
an-x%mple-domain.com
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz
my'domain.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)