using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z0-9][A-Za-z0-9-]*)([\.\_]?[A-Za-z0-9-]+)*(\.[A-Za-z]{2,6})+(\/[A-Za-z][A-Za-z0-9-]+)*$";
string input = @"webmail.eltecore.com.qqqqqqqqqqqqqqqqqqq.......";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}