package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Za-z0-9][A-Za-z0-9-]*)([\.\_]?[A-Za-z0-9-]+)*(\.[A-Za-z]{2,6})+(\/[A-Za-z][A-Za-z0-9-]+)*$`)
var str = `webmail.eltecore.com.qqqqqqqqqqqqqqqqqqq.......`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}