re = /^([A-Za-z0-9][A-Za-z0-9-]*)([\.\_]?[A-Za-z0-9-]+)*(\.[A-Za-z]{2,6})+(\/[A-Za-z][A-Za-z0-9-]+)*$/
str = 'webmail.eltecore.com.qqqqqqqqqqqqqqqqqqq.......'
# Print the match result
str.match(re) do |match|
puts match.to_s
end