$re = '/(?i)^(?=.*[a-z])[a-z0-9]{8,20}$/m';
$str = 'abc987dfsgsdf
12345678
Absdf9898798
dasfkjhslgfkha';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;