using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\d,.])\d{1,2}(?:[.,]\d{1,2})?(?![\d,.])";
string input = @",1
.1
1
10
10,5
333,5
5,555
10.50
blabla 10.5 blabla";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}