# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(_\()|(_n\())[\w", ()%]+(?=\))//gmi;t' <<< "_(\"foo\") // want \"foo\"
_n(\"bar\", \"baz\", 42); // want \"bar\", \"baz\", 42
_n(domain, \"bux\", var); // want domain, \"bux\", var
_( \"one (optional)\" ); // want \"one optional\"
apples === 0 ? _( \"No apples\" ) : _n(\"%1 apple\", \"%1 apples\", apples) // could have on the same line two calls.."