import re
regex = re.compile(r"(?<=(_\()|(_n\())[\w\", ()%]+(?=\))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("_(\"foo\") // want \"foo\"\n"
"_n(\"bar\", \"baz\", 42); // want \"bar\", \"baz\", 42\n"
"_n(domain, \"bux\", var); // want domain, \"bux\", var\n"
"_( \"one (optional)\" ); // want \"one optional\"\n"
"apples === 0 ? _( \"No apples\" ) : _n(\"%1 apple\", \"%1 apples\", apples) // could have on the same line two calls..")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)