re = /(\([^)]*\))/
str = '\'this is my string (anything within brackets)\''
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result