re = /(-?(?:\d+)?\.?\d+)/
str = 'M0.286-3.099-0.44c-2.901,-0.436,,,123,0.123,.34.34.34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end