# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<li>.*\K/<\/li>/g;t' <<< "<li>some text
more text
<li>some other text
any more text"