package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})`)
var str = []byte(`https://gyazo.com/683fd0d45622162038ee0aed541c45e4`)
var substitution = []byte("https://i.gyazo.com/$1.png")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}