$re = '/https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})/';
$str = 'https://gyazo.com/683fd0d45622162038ee0aed541c45e4';
$subst = "https://i.gyazo.com/$1.png";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;