re = /^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\/(\d|[12]\d|3[01]))?$/m
str = '10.120.15.30/28
172.181.30.0/24
192.168.1.2
192.168.1.2.3
192.168.1.2.
172.181.30.0/100
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end