import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+(9[976]\\d|8[987530]\\d|6[987]\\d|5[90]\\d|42\\d|3[875]\\d|\n"
+ "2[98654321]\\d|9[8543210]|8[6421]|6[6543210]|5[87654321]|\n"
+ "4[987654310]|3[9643210]|2[70]|7|1)\\d{1,14}$";
final String string = "+962789719773\n"
+ "+9023847298\n"
+ "00962789719773\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}