package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*(\d+(?:\.\d+)?)(?:\s*\-\s*(\d+(?:\.\d+)?))?\s*$`)
var str = ` 1.000 - 2 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}