package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{1,2}-(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)(-\d{2})?$`)
var str = `1-Apr-17`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}