using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(vitae)\b(?![^[]*]\s*\()";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc rhoncus arcu sed libero pulvinar venenatis. Curabitur fermentum aliquam metus. Mauris tempor cursus blandit. Integer at diam semper, imperdiet leo at, egestas elit. Proin pellentesque, turpis et laoreet blandit, ligula nisl dictum massa, ut finibus nunc magna sed ex. Pellentesque nec suscipit lectus. Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere cubilia Curae; In dictum lacus eget nibh laoreet condimentum. Vitae laoreet augue. Sed nulla nunc, suscipit nec lectus vitae, vestibulum iaculis nisl. Nulla leo ligula, euismod ac vehicula sed, hendrerit ac risus. Quisque non mauris a magna interdum bibendum tempor et magna. Cras tempus convallis tellus, non elementum diam lobortis eu.


Vestibulum ante dui, dapibus sed est tincidunt, bibendum mattis ex. Vivamus blandit mauris arcu, ornare pretium eros pretium sed. Donec molestie augue auctor, sollicitudin massa vel, tristique nisl. Donec nulla leo, vehicula sit amet sagittis non, dictum eget mi. Morbi suscipit id justo vel rutrum. Nullam lacus eros, consequat vitae orci a, ultrices aliquam enim. Nam finibus varius mattis. Nunc consequat ex eu nisi dapibus sagittis. Donec dictum est eu sapien viverra sollicitudin. Duis ut tempor metus. Nullam aliquam dui sit amet nibh dignissim bibendum. Duis et metus imperdiet, suscipit dolor in, vestibulum metus. Nullam egestas nulla a mi lobortis venenatis. Sed facilisis erat elit, nec ullamcorper ligula condimentum vitae. Nunc mollis nisi quis tortor consectetur sagittis.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}