const regex = /var informations ?= ?{(?=.*"titre" ?: ?(?:(?:"(?:[^"]|\\")*[^\\]")|(?:'(?:[^']|\\')*[^\\]')))(?=.*"typeTableaux" ?: ?\[ ?(?:(?:(?:"(?:[^"]|\\")*[^\\]")|(?:'(?:[^']|\\')*[^\\]'))(?:(?: ?, ?(?=["']))|(?: ?))){3} ?\])(?=.*"genreTableaux" ?: ?(["'])[mf]\1)(?=.*"typeElements" ?: ?\[ ?(?:(?:(?:"(?:[^"]|\\")*[^\\]")|(?:'(?:[^']|\\')*[^\\]'))(?:(?: ?, ?(?=["']))|(?: ?))){2} ?\])(?=.*"genreElements" ?: ?(["'])[mf]\2)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('var informations ?= ?{(?=.*"titre" ?: ?(?:(?:"(?:[^"]|\\\\")*[^\\\\]")|(?:\'(?:[^\']|\\\\\')*[^\\\\]\')))(?=.*"typeTableaux" ?: ?\\[ ?(?:(?:(?:"(?:[^"]|\\\\")*[^\\\\]")|(?:\'(?:[^\']|\\\\\')*[^\\\\]\'))(?:(?: ?, ?(?=["\']))|(?: ?))){3} ?\\])(?=.*"genreTableaux" ?: ?(["\'])[mf]\\1)(?=.*"typeElements" ?: ?\\[ ?(?:(?:(?:"(?:[^"]|\\\\")*[^\\\\]")|(?:\'(?:[^\']|\\\\\')*[^\\\\]\'))(?:(?: ?, ?(?=["\']))|(?: ?))){2} ?\\])(?=.*"genreElements" ?: ?(["\'])[mf]\\2)', 'g')
const str = `var informations = { "titre": '6 albums de sonates de D. Scarlatti numérotées selon le catalogue <abbr title="Kirkpatrick">Kk</abbr>', "typeTableaux": ["album", "albums", "album(s)"], "genreTableaux": "m", "typeElements": ["piste", "pistes"], "genreElements": "f"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}