re = /(?<protocol>s?ftp):\/\/(?:(?<user>[^@\s]+)@)?(?<host>[^\?\s\:]+)(?:\:(?<port>[0-9]+))?(?:\?(?<password>.+))?/
str = 'ftp://anonymous@example.net:21
ftp://wearenaive.net
ftp://127.0.0.1
sftp://authenticatedUser@securesite.com:558?password'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end