const regex = /([a-z0-9\+]*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z0-9\\+]*)', 'gi')
const str = `content/foo/B6128/8918/foo+bar+foo`;
const subst = `'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);