use strict;
my $str = 'content/foo/B6128/8918/foo+bar+foo';
my $regex = qr/([a-z0-9\+]*)/ip;
my $subst = '\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";