#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>"
Local $sString = "<p>The Non-compliance Risk grid has been updated. </p>\r\n<p><a href=\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\">Available here.</a> </p>\r\n\r\n<form>\r\n First name: \r\n <input type=\"text\" name=\"first_name\" value=\"\" maxlength=\"100\">\r\n <br>\r\n \r\n Last name: \r\n <input type=\"text\" name=\"last_name\" value=\"\" maxlength=\"100\">\r\n <input type=\"submit\" value=\"Submit\">\r\n </form>\r\n\r\nTesting"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")