import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<form\\s*[^>]*\\s*href\\s*=\\s*((?:[^ ]|[\\n\\r])+)\\s*[^>]*>\\s*Text\\s*<\\/form>";
final String string = "<p>The Non-compliance Risk grid has been updated. </p>\\r\\n<p><a href=\\\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\\\">Available here.</a> </p>\\r\\n\\r\\n<form>\\r\\n First name: \\r\\n <input type=\\\"text\\\" name=\\\"first_name\\\" value=\\\"\\\" maxlength=\\\"100\\\">\\r\\n <br>\\r\\n \\r\\n Last name: \\r\\n <input type=\\\"text\\\" name=\\\"last_name\\\" value=\\\"\\\" maxlength=\\\"100\\\">\\r\\n <input type=\\\"submit\\\" value=\\\"Submit\\\">\\r\\n </form>\\r\\n\\r\\nTesting";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}