using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((--foo ))([(((--)\w+)( \w+))]+)( --number )\d+$";
string input = @"--foo --bar baz --zac big --number 1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}