const regex = /^[0-9]+(?:\+[0-9]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+(?:\\+[0-9]+)*$', 'gm')
const str = `1+2
3
1+22+3
+1+2
1+
a+1+b+c
12+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}