// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)@\[(\w+)\]\(id\:\s(\d+)\)").unwrap();
let string = "He is @[otheruser](id: 100) and he is..
";
let substitution = "<a href=\"view/\\2\">@\\1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}