$re = '/^[2-9]{1}\d{0,3}$/m';
$str = '1
2
3
4
1000
2000
2565
32+6253
62
0232';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);