use strict;
my $str = 'Иванов Иван Иванович';
my $regex = qr/\w{2}(\s|$)/up;
my $subst = '*$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";