$re = '/^(?=[^0-9\n]*[0-9])(?=[^a-z\n]*[a-z]).*$/im';
$str = 'asd12
Asd123
Asd123@
Text text
1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);