using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^{].*=([^=]*)=.*[^}]";
string input = @"Should not match:
fyfffy d { dffd =heyyyy= g g dsg gs } d xgg g
Should match:
fyfffy d dffd =heyyyy= g g dsg gs d xgg g";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}