package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^{].*=([^=]*)=.*[^}]`)
var str = `Should not match:
fyfffy d { dffd =heyyyy= g g dsg gs } d xgg g
Should match:
fyfffy d dffd =heyyyy= g g dsg gs d xgg g`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}