import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\{].*=([^=]*)=.*[^\\}]";
final String string = "Should not match:\n\n"
+ "fyfffy d { dffd =heyyyy= g g dsg gs } d xgg g\n\n\n"
+ "Should match:\n\n\n"
+ "fyfffy d dffd =heyyyy= g g dsg gs d xgg g";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}