$re = '/[^{].*=([^=]*)=.*[^}]/';
$str = 'Should not match:
fyfffy d { dffd =heyyyy= g g dsg gs } d xgg g
Should match:
fyfffy d dffd =heyyyy= g g dsg gs d xgg g';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);