re = /[^{].*=([^=]*)=.*[^}]/
str = 'Should not match:
fyfffy d { dffd =heyyyy= g g dsg gs } d xgg g
Should match:
fyfffy d dffd =heyyyy= g g dsg gs d xgg g'
# Print the match result
str.match(re) do |match|
puts match.to_s
end