#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s{2,}"
Local $sString = "AALL YEAR" & @CRLF & _
"A ALL YEAR" & @CRLF & _
"A ALL YEAR" & @CRLF & _
"A ALL YEAR" & @CRLF & _
"A ALL YEAR" & @CRLF & _
"A ALL YEAR"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)