import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s{2,}";
final String string = "AALL YEAR\n"
+ "A ALL YEAR\n"
+ "A ALL YEAR\n"
+ "A ALL YEAR\n"
+ "A ALL YEAR\n"
+ "A ALL YEAR";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}