use strict;
my $str = 'AALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR';
my $regex = qr/\s{2,}/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";