re = /\s{2,}/
str = 'AALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result