import Foundation
let pattern = #"\s{2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)