import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{3}-\\d{3}-\\d{4}$";
final String string = "XXX-XXX-XXX\n"
+ "XX=XXXX^XXX\n"
+ "XXXXX@XX.XX";
final String subst = "(\\1)(\\3)(\\5)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}