use strict;
my $str = 'XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX';
my $regex = qr/^\d{3}-\d{3}-\d{4}$/p;
my $subst = '(\\1)(\\3)(\\5)';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";