re = /[\u0000-\uFFFF]/m
str = 'asd😂 ads😂ads
asd🖑😂😂😂😂asd
dasd😂asd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result