#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/(youtu\.be|(www\.|m\.)?youtube(-nocookie)?\.com)(?P<viddeo_id>\/(.*)([?&]v=[a-zA-Z0-9_-]{11})|((\/attribution|\/oembed).*(v%3D[a-zA-Z0-9_-]{11}))|(\/shorts\/[a-zA-Z0-9_-]{11})|(\/embed\/[a-zA-Z0-9_-]{11})|(\/v\/[a-zA-Z0-9_-]{11})|((\/user)(\/.+1\/)([a-zA-Z0-9_-]{11}))|(\/e\/[a-zA-Z0-9_-]{11})|(\/live\/[a-zA-Z0-9_-]{11})|\/watch\/[a-zA-Z0-9_-]{11}|\/[a-zA-Z0-9_-]{11})"
Local $sString = "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o" & @CRLF & _
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"http://www.youtube.com/embed/0zM3nApSvMg?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg" & @CRLF & _
"http://youtu.be/0zM3nApSvMg" & @CRLF & _
"https://youtube.com/shorts/0dPkkQeRwTI?feature=share" & @CRLF & _
"https://youtube.com/shorts/0dPkkQeRwTI" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=-wtIMTCHWuI" & @CRLF & _
"http://youtube.com/watch?v=-wtIMTCHWuI" & @CRLF & _
"http://m.youtube.com/watch?v=-wtIMTCHWuI" & @CRLF & _
"https://www.youtube.com/watch?v=lalOy8Mbfdc" & @CRLF & _
"https://youtube.com/watch?v=lalOy8Mbfdc" & @CRLF & _
"https://m.youtube.com/watch?v=lalOy8Mbfdc" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"http://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"http://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"https://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"https://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"https://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"http://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"http://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"https://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"https://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"https://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"http://youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"http://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"https://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"https://youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"https://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"http://youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"http://m.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"https://www.youtube.com/watch?v=oTJRivZTMLs&feature=channel" & @CRLF & _
"https://youtube.com/watch?v=oTJRivZTMLs&feature=channel" & @CRLF & _
"https://m.youtube.com/watch?v=oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"http://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"http://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"https://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"https://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"https://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be" & @CRLF & _
"http://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be" & @CRLF & _
"http://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be" & @CRLF & _
"https://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be" & @CRLF & _
"https://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be" & @CRLF & _
"https://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"https://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"https://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"https://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"http://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"http://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"https://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"https://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"https://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"http://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"http://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"https://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"https://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ" & @CRLF & _
"http://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ" & @CRLF & _
"http://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ" & @CRLF & _
"https://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ" & @CRLF & _
"https://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch/-wtIMTCHWuI" & @CRLF & _
"http://youtube.com/watch/-wtIMTCHWuI" & @CRLF & _
"http://m.youtube.com/watch/-wtIMTCHWuI" & @CRLF & _
"https://www.youtube.com/watch/-wtIMTCHWuI" & @CRLF & _
"https://youtube.com/watch/-wtIMTCHWuI" & @CRLF & _
"https://m.youtube.com/watch/-wtIMTCHWuI" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch/-wtIMTCHWuI?app=desktop" & @CRLF & _
"http://youtube.com/watch/-wtIMTCHWuI?app=desktop" & @CRLF & _
"http://m.youtube.com/watch/-wtIMTCHWuI?app=desktop" & @CRLF & _
"https://www.youtube.com/watch/-wtIMTCHWuI?app=desktop" & @CRLF & _
"https://youtube.com/watch/-wtIMTCHWuI?app=desktop" & @CRLF & _
"https://m.youtube.com/watch/-wtIMTCHWuI?app=desktop" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"http://youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"http://m.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"https://youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"https://m.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"http://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"http://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"https://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"https://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"https://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"http://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"http://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"https://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"https://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"https://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/-wtIMTCHWuI" & @CRLF & _
"https://youtu.be/-wtIMTCHWuI" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"https://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b" & @CRLF & _
"https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/oTJRivZTMLs&feature=channel" & @CRLF & _
"https://youtu.be/oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/lalOy8Mbfdc?t=1" & @CRLF & _
"http://youtu.be/lalOy8Mbfdc?t=1s" & @CRLF & _
"https://youtu.be/lalOy8Mbfdc?t=1" & @CRLF & _
"https://youtu.be/lalOy8Mbfdc?t=1s" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-" & @CRLF & _
"https://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/embed/lalOy8Mbfdc" & @CRLF & _
"http://youtube.com/embed/lalOy8Mbfdc" & @CRLF & _
"http://m.youtube.com/embed/lalOy8Mbfdc" & @CRLF & _
"https://www.youtube.com/embed/lalOy8Mbfdc" & @CRLF & _
"https://youtube.com/embed/lalOy8Mbfdc" & @CRLF & _
"https://m.youtube.com/embed/lalOy8Mbfdc" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"http://youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"http://m.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"https://www.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"https://youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"https://m.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0" & @CRLF & _
"https://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"http://youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"http://m.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"https://youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"https://m.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/shorts/j9rZxAF3C0I" & @CRLF & _
"http://youtube.com/shorts/j9rZxAF3C0I" & @CRLF & _
"http://m.youtube.com/shorts/j9rZxAF3C0I" & @CRLF & _
"https://www.youtube.com/shorts/j9rZxAF3C0I" & @CRLF & _
"https://youtube.com/shorts/j9rZxAF3C0I" & @CRLF & _
"https://m.youtube.com/shorts/j9rZxAF3C0I" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop" & @CRLF & _
"http://youtube.com/shorts/j9rZxAF3C0I?app=desktop" & @CRLF & _
"http://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop" & @CRLF & _
"https://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop" & @CRLF & _
"https://youtube.com/shorts/j9rZxAF3C0I?app=desktop" & @CRLF & _
"https://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/live/8hBmepWUJoc" & @CRLF & _
"http://youtube.com/live/8hBmepWUJoc" & @CRLF & _
"http://m.youtube.com/live/8hBmepWUJoc" & @CRLF & _
"https://www.youtube.com/live/8hBmepWUJoc" & @CRLF & _
"https://youtube.com/live/8hBmepWUJoc" & @CRLF & _
"https://m.youtube.com/live/8hBmepWUJoc" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/live/8hBmepWUJoc?app=desktop" & @CRLF & _
"http://youtube.com/live/8hBmepWUJoc?app=desktop" & @CRLF & _
"http://m.youtube.com/live/8hBmepWUJoc?app=desktop" & @CRLF & _
"https://www.youtube.com/live/8hBmepWUJoc?app=desktop" & @CRLF & _
"https://youtube.com/live/8hBmepWUJoc?app=desktop" & @CRLF & _
"https://m.youtube.com/live/8hBmepWUJoc?app=desktop" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"http://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"http://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"https://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"https://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"https://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"http://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"http://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"https://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"https://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"https://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail" & @CRLF & _
"http://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail" & @CRLF & _
"http://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail" & @CRLF & _
"https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail" & @CRLF & _
"https://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail" & @CRLF & _
"https://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")