const regex = new RegExp('^(?!www\\.|(?:http|ftp)s?://|[A-Za-z]:\\\\|//).*', 'gm')
const str = `y protocol or double slash //
C:\\File
about.html
tutorial1/
tutorial1/2.html
/
/experts/
../
../experts/
../../../
./
./about.html
http://google.com
www.google.com
//dub-server1/mynode`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}