# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\%This\.|\&)[A-Za-z]+\.DESCR/name: $1; data = $2/gm;t' <<< "%This.oPosition.DESCR =
&data.DESCR ="