const regex = /(?<dir>[\-d])(?<permission>([\-r][\-w][\-xt]){3})\s+\d+\s+\w+\s+\w+\s+(?<size>\d+)\s+(?<timestamp>\w+\s+\d+\s+\d{1,2}:\d{2})\s+(?<name>.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<dir>[\\-d])(?<permission>([\\-r][\\-w][\\-xt]){3})\\s+\\d+\\s+\\w+\\s+\\w+\\s+(?<size>\\d+)\\s+(?<timestamp>\\w+\\s+\\d+\\s+\\d{1,2}:\\d{2})\\s+(?<name>.+)', '')
const str = `drwxrwxrwt 2 0 0 4096 May 18 14:50 deposit_slip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}