#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)"
Local $sString = "https://www.instagram.com/Worldfoodprogramme/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)