use strict;
my $str = 'https://www.instagram.com/Worldfoodprogramme/';
my $regex = qr/(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";